We’re currently investigating an issue causing blank pages in the Screenly interface for some users.

Incident Report for Screenly

Resolved

This incident has now been resolved.
Posted Jul 21, 2025 - 18:13 UTC

Monitoring

The update has now been rolled back, and we are seeing the normal operation of the web console return by refreshing the browser session.
Posted Jul 21, 2025 - 17:31 UTC

Identified

Our developers have identified an issue related to a deployment earlier today, and the process of rolling back the update is in-progress.
Posted Jul 21, 2025 - 16:45 UTC

Investigating

We are currently investigating this issue.
Posted Jul 21, 2025 - 16:00 UTC
This incident affected: Frontend (Marketing Site).