Issue with Group and Screen Labels.
Incident Report for Screenly
Resolved
This incident has been resolved.
Posted Dec 13, 2023 - 10:01 UTC
Investigating
We're currently investigating an issue with labels failing to load or loading very slowly in our web console.
Posted Dec 13, 2023 - 01:18 UTC