We're currently investigating issues with logging into the web console and registering devices.

Incident Report for Screenly

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:29 UTC

Update

All Screenly production systems appear to be fully operational, however, we are monitoring to ensure there is no degradation of service.

Google Engineers have also mitigated the issues within the us-central1 region, and expect full recovery within the next hour.

For the latest update, Google's status page for the incident can be followed here: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 21:01 UTC

Monitoring

All Screenly production systems appear to be fully operational, however, we are monitoring to ensure there is no degradation of service.

Google Engineers have also mitigated the issues within the us-central1 region, and expect full recovery within the next hour.

For the latest update, Google's status page for the incident can be followed here: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 21:00 UTC

Identified

Google's Engineering team has identified the root cause and began implementing mitigation and recovery processes. They have confirmed that the underlying dependency is recovered in all locations except us-central1, but noted that "many customers are still experiencing varying degrees of impact on individual google cloud products." The Google engineering teams are continuing to work on restoring service, and there is no ETA at this time.

For the complete update, Google's status page for the incident can be followed here: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 19:41 UTC

Update

One of our cloud service providers, Google Cloud (GCP), has identified a major service outage affecting multiple GCP products and customers. This is currently being investigated by the Google Engineering team.

Google's status page for the incident can be followed here: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 18:46 UTC

Investigating

We are currently investigating this issue.
Posted Jun 12, 2025 - 18:13 UTC
This incident affected: Frontend (Login Page) and Backend (Device Registration, Auth, API v3).