We're currently investigating an issue with labels failing to load or loading very slowly in our web console, in addition to overall web console responsiveness.
Incident Report for Screenly
Resolved
This incident has been resolved.
Posted Feb 16, 2024 - 11:02 UTC
Update
Our team is continuing our investigation into this issue.
Posted Feb 15, 2024 - 22:09 UTC
Investigating
We are currently investigating this issue.
Posted Feb 15, 2024 - 20:00 UTC